Какая ссылка на ячейку в microsoft excel является неправильной
Перейти к содержимому

Какая ссылка на ячейку в microsoft excel является неправильной

  • автор:

Изменение типа ссылки: относительная, абсолютная, смешанная

По умолчанию ссылка на ячейку является относительной ссылкой, что означает, что ссылка относится к расположению ячейки. Если, например, вы ссылаетесь на ячейку A2 из ячейки C2, вы фактически ссылаетесь на ячейку, которая является двумя столбцами слева (C минус A) в одной строке (2). При копировании формулы, содержащей относительную ссылку на ячейку, эта ссылка в формуле изменится.

Например, если скопировать формулу =B4*C4 из ячейки D4 в D5, формула в D5 адаптируется вправо на один столбец и станет =B5*C5. Если вы хотите сохранить исходную ссылку на ячейку в этом примере при ее копировании, необходимо сделать ссылку на ячейку абсолютной перед столбцами (B и C) и строкой (2) со знаком доллара ($). Затем при копировании формулы =$B$4*$C$4 из D4 в D5 формула остается точно такой же.

Ссылка на относительную ячейку

Реже может потребоваться смешивать абсолютные и относительные ссылки на ячейки, перед столбцом или значением строки со знаком доллара, который исправляет столбец или строку (например, $B 4 или C$4).

Чтобы изменить тип ссылки на ячейку, выполните следующее.

  1. Выделите ячейку с формулой.
  2. В строке формул строка формул

Копируемая формула

Первоначальная ссылка

Новая ссылка

$A$1 (абсолютный столбец и абсолютная строка)

$A$1 (абсолютная ссылка)

A$1 (относительный столбец и абсолютная строка)

C$1 (смешанная ссылка)

$A1 (абсолютный столбец и относительная строка)

$A3 (смешанная ссылка)

A1 (относительный столбец и относительная строка)

C3 (относительная ссылка)

Описание управления ссылками на книги и хранения в Excel

В Microsoft Excel можно связать ячейку в книге с другой книгой с помощью формулы, которая ссылается на внешнюю книгу. Это называется ссылкой на книгу. При создании этой ссылки на книгу она может использовать относительный путь, который позволяет перемещать книги без разрыва ссылки. В этой статье описывается, как ссылки на книги хранятся в Excel при различных обстоятельствах, и может помочь при попытке исправить неработающую ссылку.

Как обрабатываются пути ссылки на книги при открытии целевой книги

Когда Excel открывает целевую книгу, содержащую ссылки на книгу, он динамически объединяет части ссылок книги, хранящиеся в книге, с необходимыми частями текущего пути к исходной книге, чтобы создать абсолютный путь.

Важно также отметить, что то, что отображается в строке формул, не обязательно является сохраненным. Например, если исходная книга закрыта, вы увидите полный путь к файлу, хотя может храниться только имя файла.

Относительные и абсолютные ссылки

По возможности ссылки на исходные книги создаются относительно. Это означает, что полный путь к исходной книге записывается не, а часть пути, связанная с целевой книгой. С помощью этого метода можно перемещать книги, не прерывая связи между ними. Однако ссылки на книги остаются нетронутыми, только если книги остаются в том же расположении относительно друг друга. Например, если целевая книга C:\Mydir\Destination.xlsx, а исходная книга — C:\Mydir\Files\Source.xlsx, можно переместить файлы на диск D, если исходная книга по-прежнему находится во вложенной папке с именем «Файлы».

Относительные ссылки могут вызвать проблемы при перемещении целевой книги на разные компьютеры, а исходная книга находится в центральном расположении.

Три типа конфигураций хранилища ссылок книг

Способ, с помощью которого создаются ссылки на книги, зависит от следующих способов:

Тип хранилища 1: тот же диск с той же папкой или дочерней папкой

Исходная книга находится в той же или дочерней папке, что и целевая книга. В этом случае мы сохраняем относительный путь к файлу, например вложенную папку/source.xlsx и destination.xlsx.

Этот тип лучше всего подходит для облачных книг и при перемещении обеих книг.

Тип хранилища 2: тот же диск, но с разными одноуровневыми папками

Исходные и целевые книги находятся на одном диске, но в разных папках одноуровневых элементов. В этом случае мы сохраняем путь относительно сервера, например /root/parent/sibling1/source.xlsx и /root/parent/sibling2/destination.xlsx.

Этот тип лучше всего подходит, если целевая книга перемещается на том же диске, но исходная книга остается в том же расположении.

Тип хранилища 3: разные диски

Исходная книга находится на диске, отличном от целевой книги. Например, конечная папка книги находится на диске C, а исходная папка книги — на диске H. В этом случае мы сохраняем абсолютный путь, например H:\folder\source.xlsx или https://tenant.sharepoint.com/teams/site/folder/source.xlsx.

Этот тип лучше всего подходит, если целевая книга перемещена, но исходная книга остается в том же расположении. При этом предполагается, что целевая книга по-прежнему может получить доступ к исходной книге.

Основные сведения о папках XLStart и Office

Если исходная книга находится в папке XLStart, Альтернативное расположение файла запуска или Библиотека , записывается свойство, указывающее одну из этих папок, и сохраняется только имя файла.

Excel распознает две папки XLStart по умолчанию, из которых автоматически открываются файлы при запуске. Эти две папки:

Папка XLStart , которая находится в профиле пользователя, — это папка XLStart , которая хранится в качестве свойства для ссылки на книгу. Если вы используете папку XLStart , которая находится в папке установки Office, эта папка XLStart обрабатывается как любая другая папка на жестком диске.

Имя папки Office изменяется в разных версиях Office. Например, имя папки Office может быть Office14, Office15 или Office16 в зависимости от версии Office, которую вы используете. Это изменение имени папки приводит к разрыву ссылок на книги при переходе на компьютер под управлением версии Excel, отличной от версии, в которой была установлена ссылка.

  • Папка XLStart , которая находится в папке установки Office, например C:\Program Files\Microsoft Office\\XLStart
  • Папка XLStart, которая находится в профиле пользователя, например C:\Documents and Settings\\Application Data\Microsoft\Excel\XLStart

Общие сведения о сопоставленных дисках и UNC

При связывании исходной книги ссылка на книгу устанавливается в зависимости от способа открытия исходной книги. Если книга была открыта на сопоставленном диске, ссылка на книгу создается с помощью сопоставленного диска. Ссылка на книгу остается таким, независимо от того, как будет открыта исходная книга в будущем. Если исходная книга открыта путем UNC, ссылка на книгу не вернется к сопоставленному диску, даже если соответствующий диск доступен. Если в одном файле имеются ссылки на UNC и сопоставленные книги диска, а исходные книги открыты одновременно с целевой книгой, то в качестве гиперссылки будут реагировать только те ссылки, которые соответствуют способу открытия исходной книги. В частности, если открыть исходную книгу на сопоставленном диске и изменить значения в исходной книге, немедленно обновятся только ссылки, созданные на сопоставленный диск.

Кроме того, ссылка на книгу, отображаемая в Excel, может отображаться по-разному в зависимости от способа открытия книги. Ссылка на книгу может показаться соответствующей корневой UNC-папке или букве корневого диска, которая использовалась для открытия файла.

Сценарии, которые могут привести к неправильной работе ссылок на книги

Существует несколько обстоятельств, при которых связи между книгами могут быть случайно установлены, чтобы указать на ошибочные расположения. Ниже приведены два наиболее распространенных сценария.

  1. Вы сопоставляете диск под корнем общей папки. Например, вы сопоставляете диск Z с \\MyServer\MyShare\MyFolder1.
  2. После открытия целевой книги на сопоставленном диске создается ссылка на исходную книгу, которая хранится в сопоставленном расположении.
  3. Вы открываете целевую книгу по пути UNC.
  4. В результате ссылка на книгу будет нарушена.

Если вы закроете целевую книгу, не сохранив ее, ссылки на нее не будут изменены. Однако если вы сохраните целевую книгу перед ее закрытием, вы сохраните ссылки на книгу с текущим неработаным путем. Папки между корнем общей папки и сопоставленной папкой останутся вне пути. В приведенном выше примере ссылка изменится на \\MyServer\MyFolder1. Иными словами, имя общего ресурса исключается из пути к файлу.

  1. Вы сопоставляете диск под корнем общей папки. Например, вы сопоставляете диск Z с \\MyServer\MyShare\MyFolder1.
  2. Файл открывается по пути UNC или сопоставленному диску, сопоставленному с другой папкой в общей папке, например \\MyServer\MyShare\MyFolder2.
  3. В результате ссылка на книгу будет нарушена.

Если вы закроете целевую книгу, не сохранив ее, ссылки на нее не будут изменены. Однако если вы сохраните целевую книгу перед ее закрытием, вы сохраните ссылки на книгу с текущим неработаным путем. Папки между корнем общей папки и сопоставленной папкой останутся вне пути. В приведенном выше примере ссылка изменится на \\MyServer\MyFolder1. Иными словами, имя общего ресурса исключается из пути к файлу.

Типы ссылок EXCEL на ячейку: относительная (A1), абсолютная ($A$1) и смешанная (A$1) адресация

В формулах EXCEL можно сослаться на значение другой ячейки используя ее адрес (=А1). Адрес ячейки в формуле можно записать по-разному, например: А1 или $A1 или $A$1. То, каким образом вы введете адрес в формулу, будет зависеть, как он будет модифицироваться при ее копировании в другие ячейки листа. Это пригодится при как построении обычных формул на листе, так и при создании Именованных формул , задания правил Условного форматирования и при формировании условий Проверки данных .

В подавляющем большинстве формул EXCEL используются ссылки на ячейки. Например, если в ячейке В1 содержится формула =А1+5 , то означает, что в ячейку В1 будет помещено значение ячейки А1 находящейся на пересечении столбца А и строки 1 , к которому прибавлено число 5. Также в формулах используются ссылки на диапазоны ячеек, например, формула =СУММ(А2:А11) вычисляет сумму значений из ячеек А2 , А3 , . А11 . Однако, формула =СУММ($А$2:$А$11) также вычисляет сумму значений из тех же ячеек. Тогда в чем же разница? Разница проявляется при копировании этой формулы в соседние ячейки.

Абсолютная адресация (абсолютные ссылки)

Для создания абсолютной ссылки используется знак $. Ссылка на диапазона записывается ввиде $А$2:$А$11 . Абсолютная ссылка позволяет при копировании формулы зафиксировать адрес диапазона или адрес ячейки. Рассмотрим пример.

Пусть в ячейке В2 введена формула =СУММ( $А$2:$А$11 ) , а в ячейке С2 формула =СУММ(А2:А11). Скопировав формулы вниз, например с помощью Маркера заполнения, во всех ячейках столбца В получим одну и ту же формулу =СУММ( $А$2:$А$11 ) , т.е. ссылка на диапазон ячеек при копировании не изменилась . А в столбце С получим другой результат: в ячейке С3 будет формула =СУММ(A3:A12) , в ячейке С4 будет формула =СУММ(A4:A13) и т.д. Т.е. при копировании ссылка была модифицирована .

Какая формула лучше? Все зависит от вашей задачи: иногда при копировании нужно фиксировать диапазон, в других случая это делать не нужно.

Другой пример.

Пусть в диапазоне А1:А5 имеются числа (например, зарплата сотрудников отдела), а в С1 – процент премии установленный для всего отдела. Для подсчета премии каждого сотрудника необходимо все зарплаты умножить на % премии. Рассчитанную премию поместим в диапазоне В1:В5 . Для этого введем в ячейку В1 формулу =А1*С1 . Если мы с помощью Маркера заполнения протянем формулу вниз, то получим в В2:В5 нули (при условии, что в диапазоне С2:С5 нет никаких значений). В ячейке В5 будем иметь формулу =А5*С5 (EXCEL при копировании формулы модифицировал ссылки на ячейки, т.к. их адреса не были записаны в виде абсолютных ссылок).

Чтобы выйти из ситуации — откорректируем формулу в ячейке В1 .

Такм образом, введем в В1 формулу =А1*$С$1 . Это можно сделать и в ручную, введя знак $ перед буквой столбца и перед номером строки.

Нажмем ENTER и протянем ее вниз. Теперь в В5 будет правильная формула =А5*$С$1 . Всем сотрудникам теперь достанется премия :).

Относительная адресация (относительные ссылки)

Введем в ячейку B1 формулу =А1 , представляющую собой относительную ссылку на ячейку А1 . Что же произойдет с формулой при ее копировании в ячейки расположенные ниже В1 ? После протягивания ее вниз Маркером заполнения , в ячейке В5 будет стоять формула =А5 , т.е. EXCEL изменил первоначальную формулу =A1 . При копировании вправо в ячейку С1 формула будет преобразована в =В1.

Теперь примеры.

Пусть в столбце А введены числовые значения. В столбце B нужно ввести формулы для суммирования значений из 2-х ячеек столбца А : значения из той же строки и значения из строки выше.

Т.е. в B2 должна быть формула: =СУММ(A1:A2) , в B3 : =СУММ(A2:A3) и т.д.

Решить задачу просто: записав в B2 формулу =СУММ(A1:A2) , протянем ее с помощью Маркера заполнения в ячейку B3 и ниже.

Альтернативное решение

Другим вариантом решения этой задачи является использование Именованной формулы . Для этого:

  • выделите ячейку B2 (это принципиально при использовании относительных ссылок в Именах ). Теперь B2 – активная ячейка;
  • на вкладке Формулы в группе Определенные имена выберите команду Присвоить имя ;
  • в поле Имя введите, например Сумма2ячеек ;
  • убедитесь, что в поле Диапазон введена формула =СУММ(A1:A2)
  • Нажмите ОК.

Теперь в B2 введем формулу = Сумма2ячеек . Результат будет тот, который мы ожидали: будет выведена сумма 2-х ячеек из столбца слева (см. файл примера , лист пример1 ). Если формулу ввести в ячейку B5 , то она будет суммировать ячейки A4:A5 , если ввести в D10 , то – ячейки С9:С10 .

Другими словами, будут суммироваться 2 ячейки соседнего столбца слева, находящиеся на той же строке и строкой выше. Ссылка на диапазон суммирования будет меняться в зависимости от месторасположения формулы на листе, но «расстояние» между ячейкой с формулой и диапазоном суммирования всегда будет одинаковым (один столбец влево).

Относительная адресация при создании формул для Условного форматирования.

Пусть необходимо выделить в таблице, содержащей числа от 1 до 100, значения больше 50, причем, только в четных строках (см. файл примера , лист пример2 ). Построим такую таблицу:

Важно отметить, что, если бы, при создании правила, активной ячейкой была F11 , то формулу необходимо было переписать: =И(ОСТАТ($A11;2)=$I$1;F11>50) . Поменять необходимо только ссылки незафиксированные знаком $: B2 на F11 и $A2 на $A11 .

Внимание! При использовании относительной адресации в Именованных формулах , Именованных диапазонах , Условном форматировании , Проверке данных (примеры см. в соответствующих статьях) необходимо следить, какая ячейка является активной в момент создания формулы (активной может быть только одна ячейка на листе, не смотря на то, что выделено может быть несколько).

Смешанные ссылки

Смешанные ссылки имеют формат =$В3 или =B$3 . В первом случае при копировании формулы фиксируется ссылка на столбец B , а строка может изменяться в зависимости при копировании формулы.

Предположим, у нас есть столбец с ценами в диапазоне B 3: B 6 (см. файл примера , лист пример3 ). В столбцах С, D , Е содержатся прогнозы продаж в натуральном выражении по годам (в шт.). Задача: в столбцах F , G , H посчитать годовые продажи в рублях, т.е. перемножить столбцы С, D , Е на столбец B . Использование механизма относительной адресации позволяет нам ввести для решения задачи только одну формулу. В ячейку F вводим: =$В3*C3 . Потом протягиваем формулу маркером заполнения вниз до F 6 ,

а затем весь столбец таблицы протягиваем вправо на столбцы G и H .

Обратите внимание, что в формуле =$В3*C3 перед столбцом B стоит значок $. При копировании формулы =$В3*C3 в ячейки столбцов F, G и H , этот значок $ говорит EXCEL о том, что ссылку на столбец B модифицировать не нужно. А вот перед столбцом С такого значка нет и формула в ячейке H6 примет вид =$В6*E6 .

Вводим знак $ в адрес ячейки

Существует несколько возможностей при вводе формулы ввести знак $ в адрес ячейки или диапазона. Рассмотрим ввод на примере формулы =СУММ($А$2:$А$5)

1. Ввести знак $ можно вручную, последовательно вводя с клавиатуры все знаки =СУММ($А$2:$А$5)

2. С помощью клавиши F4 (для ввода абсолютной ссылки):

  • Введите часть формулы без ввода $: =СУММ(А2:А5
  • Затем сразу нажмите клавишу F4 , знаки $ будут вставлены автоматически: =СУММ( $А$2:$А$5
  • Для окончания ввода формулы нажмите ENTER.

Если после ввода =СУММ(А2:А5 в формуле передвинуть курсор с помощью мыши в позицию левее,

а затем вернуть его в самую правую позицию (также мышкой),

то после нажатия клавиши F4 , знаки $ будут автоматически вставлены только во вторую часть ссылки! =СУММ( А2:$А$5

Чтобы вставить знаки $ во всю ссылку, выделите всю ссылку А2:$А$5 или ее часть по обе стороны двоеточия, например 2:$А , и нажмите клавишу F4. Знаки $ будут автоматически вставлены во всю ссылку $А$2:$А$5

3. С помощью клавиши F4 (для ввода относительной ссылки).

  • Введите часть формулы без ввода $: =СУММ(А2:А5
  • Затем сразу нажмите клавишу F4 , будут автоматически вставлены знаки $: =СУММ( $А$2:$А$5
  • Еще раз нажмите клавишу F4 : ссылка будет модифицирована в =СУММ( А$2:А$5 (фиксируются строки)
  • Еще раз нажмите клавишу F4 : ссылка будет модифицирована в =СУММ($ А2:$А5 (фиксируется столбец)
  • Еще раз нажмите клавишу F4 : ссылка будет модифицирована в =СУММ( А2:А5 (относительная ссылка). Последующие нажатия изменяют ссылку заново по кругу.
  • Для окончания ввода нажмите ENTER.

Чтобы изменить только первую или втрорую часть ссылки — установите мышкой курсор в нужную часть ссылки и последовательно нажимайте клавушу F4.

«СуперАбсолютная» адресация

В заключении расширим тему абсолютной адресации. Предположим, что в ячейке B 2 находится число 25, с которым необходимо выполнить ряд вычислений, например, возвести в разные степени (см. файл примера , лист пример4 ). Для этого в столбце C напишем формулу возведения в степень (значения степени введем в столбец D ): =$B$2^$D2 .

Мы использовали абсолютную ссылку на ячейку B 2 . При любых изменениях положения формулы абсолютная ссылка всегда будет ссылаться на ячейку, содержащую наше значение 25 :

  • при копировании формулы из С3 в Н3 – формула не изменится, и мы получим правильный результат 625 ;
  • при вставке нового столбца между столбцами А и В – формула превратится в =$C$2^$E3 , но мы снова получим правильный результат 625 .

Все правильно, т.к. это и есть суть абсолютной адресации: ссылки автоматически модифицируются для сохранения адресации на нужные ячейки при любых модификациях строк и столбцах листа (ну, кроме удаления ячейки с формулой, конечно). Однако бывают ситуации, когда значения на лист попадают из внешних источников. Например, когда созданный пользователем макрос вставляет внешние данные в ячейку B 2 (т.е. всегда во второй столбец листа). Теперь, при вставке столбца между столбцами А и В – формула как и раньше превратится в =$C$2^$E3 , но т.к. исходное число (25) будет вставляться макросом не в С2 , а по прежнему в ячейку B 2 , и мы получим неправильный результат.

Вопрос: можно ли модифицировать исходную формулу из С2 ( =$B$2^$D2 ), так чтобы данные все время брались из второго столбца листа и независимо от вставки новых столбцов?

Решение заключается в использовании функции ДВССЫЛ() , которая формирует ссылку на ячейку из текстовой строки. Если ввести в ячейку формулу: =ДВССЫЛ(«B2») , то она всегда будет указывать на ячейку с адресом B2 вне зависимости от любых дальнейших действий пользователя, вставки или удаления столбцов и т.д.

Небольшая сложность состоит в том, что если целевая ячейка пустая, то ДВССЫЛ() выводит 0, что не всегда удобно. Однако, это можно легко обойти, используя чуть более сложную конструкцию с проверкой через функцию ЕПУСТО() :

При ссылке на ячейку В2 с другого листа =ДВССЫЛ(«пример4!B2») может возникнуть и другая сложность: при изменении названия листа пример4 – формула перестает работать. Но это также можно обойти – см. пример из статьи Определяем имя листа .

Другим способом заставить формулу ссылаться на один и тот же столбец является использование функции СМЕЩ() – об этом читайте статью Как заставить формулу все время ссылаться на один и тот же столбец .

Как исправить #REF! ошибка

Excel для Microsoft 365 Excel для Microsoft 365 для Mac Excel для Интернета Excel 2021 Excel 2021 для Mac Excel 2019 Excel 2019 для Mac Excel 2016 Excel 2016 для Mac Excel 2013 Excel для iPad Excel для iPhone Excel для планшетов с Android Excel для телефонов с Android Excel для Windows Phone 10 Excel Mobile Excel Starter 2010 Еще. Меньше

Ошибка #REF! отображается, когда формула ссылается на недопустимую ячейку. Чаще всего это происходит потому, что формула ссылается на ячейки, которые были удалены или заменены другими данными.

#ССЫЛКА! из-за удаления столбца

В следующем примере в столбце E используется формула =СУММ(B2;C2;D2).

Формула с явными ссылками на ячейки, например =SUM(B2,C2,D2), может вызвать #REF! ошибка при удалении столбца.

Удаление столбцов B, C или D приведет к #REF! ошибку #ЗНАЧ!. В этом случае мы удалим столбец C (Продажи 2007), а формула теперь будет читать =СУММ(B2,#REF!,C2). Если вы используете явные ссылки на ячейки, как это (когда вы ссылаетесь на каждую ячейку по отдельности, разделенные запятой) и удаляете строку или столбец, на которые ссылается ссылка, Excel не может разрешить их, поэтому он возвращает #REF! ошибку #ЗНАЧ!. Это основная причина, по которой не рекомендуется использовать явные ссылки на ячейки в функциях.

Пример ошибки #ССЫЛКА! из-за удаления столбца.

  • Если вы случайно удалили строки или столбцы, вы можете немедленно нажать кнопку «Отменить» на панели быстрого доступа (или нажать клавиши CTRL+Z), чтобы восстановить их.
  • Измените формулу так, чтобы она ссылалась на диапазон, а не на отдельные ячейки, например =СУММ(B2:D2). Теперь можно удалить любой столбец в диапазоне суммирования, и Excel автоматически скорректирует формулу. Чтобы вычислить сумму значений в строках, также можно использовать формулу =СУММ(B2:B5).

Пример функции ВПР с неправильными ссылками на диапазоны

В следующем примере =VLOOKUP(A8;A2:D5;5;FALSE) вернет #REF! ошибка, так как она ищет значение, возвращаемое из столбца 5, но диапазон ссылок — A:D, то есть только 4 столбца.

Пример формулы ВПР с неправильным диапазоном. Формула =VLOOKU(A8;A2:D5;5;FALSE). В диапазоне ВПР нет пятого столбца, поэтому значение 5 вызывает #REF! ошибку #ЗНАЧ!.

Расширьте диапазон или уменьшите значение столбца для поиска так, чтобы он попадал в указанный диапазон. Формулы =ВПР(A8;A2:E5;5;ЛОЖЬ) будет работать правильно, так же как и формула =ВПР(A8;A2:D5;4;ЛОЖЬ).

INDEX с неправильной ссылкой на строку или столбец

В этом примере формула =INDEX(B2:E5,5;5) возвращает #REF! ошибка, так как диапазон INDEX состоит из 4 строк на 4 столбца, но формула запрашивает возвращать значения в 5-й и 5-й строках.

Пример формулы ИНДЕКС с недопустимой ссылкой на диапазон. Формула имеет вид =ИНДЕКС(B2:E5;5;5), но диапазон содержит всего 4 строки и 4 столбца.

Измените ссылки на строки и столбцы так, чтобы они попадали в диапазон поиска функции ИНДЕКС. Формула =ИНДЕКС(B2:E5;4;4) вернет правильный результат.

Ссылка на закрытую книгу с помощью INDIRECT

В следующем примере функция INDIRECT пытается ссылаться на закрытую книгу, вызывая #REF! ошибку #ЗНАЧ!.

Пример ошибки #ССЫЛКА! из-за использования функции ДВССЫЛ для ссылки на закрытую книгу.

Откройте книгу, на который ссылается ссылка. Эта же ошибка возникает при ссылке на закрытую книгу с динамической функцией массива.

Структурированные ссылки не поддерживаются

Структурированные ссылки на имена таблиц и столбцов в связанных книгах не поддерживаются.

Вычисляемые ссылки не поддерживаются

Вычисляемые ссылки на связанные книги не поддерживаются.

Ошибка недопустимой ссылки на ячейку

Перемещение или удаление ячеек вызвало недопустимую ссылку на ячейку, или функция возвращает ошибку ссылки.

Проблемы с OLE

Если вы использовали ссылку OLE, которая возвращает #REF! ошибка, а затем запустите программу, которую вызывает ссылка.

Примечание: OLE — это технология, которая используется для обмена информацией между приложениями.

Проблемы С DDE

Если вы использовали раздел динамического обмена данными (DDE), возвращающий #REF! Ошибка, сначала проверка, чтобы убедиться, что вы ссылаетесь на правильный раздел. Если вы по-прежнему получаете #REF! ошибка, проверка параметры центра управления безопасностью для внешнего содержимого, как описано в разделе Блокировать или разблокировать внешнее содержимое в документах Microsoft 365.

Примечание. Динамический обмен данными (DDE)— это установленный протокол для обмена данными между программами на базе Microsoft Windows.

Проблемы с макросами

Если макрос вводит на листе функцию, которая ссылается на ячейку над функцией, а ячейка, содержащая функцию, находится в строке 1, функция вернет #REF! поскольку нет ячеек над строкой 1. Проверьте функцию, чтобы узнать, ссылается ли аргумент на ячейку или диапазон ячеек, которые недопустимы. Для этого может потребоваться изменить макрос в редакторе Visual Basic (VBE), чтобы учесть эту ситуацию.

Дополнительные сведения

Вы всегда можете задать вопрос эксперту в Excel Tech Community или получить поддержку в сообществах.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *