Как удалить пользовательские настройки формы документа 1с
Перейти к содержимому

Как удалить пользовательские настройки формы документа 1с

  • автор:

Как удалить пользовательские настройки формы документа 1с

Сделал обработку которая показывает движения документов по регистрам.
1)Колонки для каждого документа формируется динамически в динамическом списке.
2) Если нажат на заголовок колонки то отрабатывает сортировка — вот как удалить эту сортировку или (порядок)?

2) Если нажать на заголовок и выбрать другой тип документа

Тока понедельник уже мозг кипить)))

(5) не уверен, но возможно это поможет. Из бсп
удаление пользовательских настроек формы
&НаСервере
Процедура СброситьРазмерыИПоложениеОкна()
КлючОбъекта = «РегистрСведений.Отправления.Форма.ФормаЗаписи/Такси/НастройкиОкна»;
ИмяПользователя = ПользователиИнформационнойБазы.ТекущийПользователь().Имя;
ХранилищеСистемныхНастроек.Удалить(КлючОбъекта,»», ИмяПользователя);
КлючСохраненияПоложенияОкна = Строка(Новый УникальныйИдентификатор);
КонецПроцедуры

Работа с пользовательскими настройками

Область применения: управляемое приложение, обычное приложение.

1.1. Для хранения персональных настроек пользователя следует использовать хранилище общих настроек. Например, чтение и запись значения настройки «Задавать вопрос при выходе из программы» для текущего пользователя реализуется на встроенном языке с помощью объекта ХранилищеОбщихНастроек :

ЗначениеНастройки = ХранилищеОбщихНастроек.Загрузить(«НастройкиПрограммы», «ЗадаватьВопросПриВыходе»);
ХранилищеОбщихНастроек.Сохранить(«НастройкиПрограммы», «ЗадаватьВопросПриВыходе», ЗначениеНастройки);

При этом для хранения настроек пользователя не следует использовать какие-либо другие способы, в частности, другие объекты метаданных (регистры, реквизиты и табличные части справочников и др.), внешние файлы и пр.

1.2. Для работы с пользовательскими настройками требуется, чтобы для пользователя было доступно право СохранениеДанныхПользователя .

1.3. Для обращения к каждой настройке в хранилище общих настроек необходимо использовать уникальный строковый ключ настройки. Например, значения основной организации и основного склада, с которыми работает текущий пользователь – это две разные настройки, которые хранятся раздельно под ключами «ОсновнаяОрганизация» и «ОсновнойСклад» .

В то же время, некоторые настройки могут быть объединены в структуру, массив или соответствие, если все обращения к ним выполняются одновременно, как к одной настройке. Например, параметры прокси-сервера для доступа к сети Интернет представляют из себя набор из нескольких значений (адрес прокси-сервер, имя и пароль пользователя), однако хранятся все вместе в виде одной структуры как одна самостоятельная настройка.

2.1. В конфигурации должно быть предусмотрено общее место для редактирования всех пользовательских настроек. Как правило, это общая форма персональных настроек пользователя.

Пример реализации формы персональных настроек «Мои настройки» имеется в демонстрационной конфигурации Библиотеки стандартных подсистем .

2.2. В то же время, форма персональных настроек может являться не единственным местом для их редактирования. Для повышения удобства работы пользователя поля с отдельными настройками могут быть размещены непосредственно в тех рабочих местах, к которым эти настройки относятся. Например, флажок «Больше не показывать подсказки при редактировании файла» может быть размещен прямо на форме с самой подсказкой, которая выводится при работе с файлами.

2.3. Форма персональных настроек пользователя, другие формы (рабочие места), а также отдельные элементы форм для работы с персональными настройками должны быть доступны только пользователям с правом СохранениеДанныхПользователя .

3.1. При работе с хранилищем общих настроек следует иметь в виду, что настройки не мигрируют между узлами информационной базы, а специфичны для определенного узла. При необходимости, передача настроек пользователей между узлами может быть реализована дополнительно средствами встроенного языка.

3.2. Все настройки в хранилище общих настроек сохраняются в разрезе пользователей информационной базы, по строковому имени пользователя. Поэтому в случае переименования пользователя прежние настройки теряются. В частности, если впоследствии будет создан пользователь, имя которого совпадает с именем переименованного пользователя, то для него будут использованы ранее сохраненные настройки.

Для того чтобы этого избежать, рекомендуется переносить настройки при переименовании пользователя, и очищать настройки при удалении.

При использовании в конфигурации Библиотеки стандартных подсистем (БСП) в распоряжении разработчика имеются обработчики записи и удаления пользователя информационной базы (см. процедуры ПриЗаписиПользователяИнформационнойБазы и ПослеУдаленияПользователяИнформационнойБазы в общем модуле ПользователиПереопределяемый ), в которых возможно выполнить перенос и удаление настроек. Пример использования см. в демонстрационной конфигурации БСП.

Очистка хранилища настроек пользователей

Не секрет, что периодически, в 1С нужно чистить настройки пользователей!

т.к. в процессе обновления программы или доработки нового функционала, форма документа, отчета меняется и старые сохраненные настройки могут неверно отображаться с новым интерфейсом. Чтобы это исправить — нужно очистить старые настройки и сохранить по новой.

Тут же хранятся настройки печатных форм документов, если документ не печатается из 1С или печатается криво, то нужно очистить настройки 1C.

Обработка очистки настроек пользователя работает в 2-х режимах:

1. Выбираете пользователя — нажимаете Очистить ВСЕ настройки пользователя — у выбранного пользователя будет очищены все старые настройки, и программу будет работать и отображаться так , как это было заложено разработчиками. Этот способ помогает избавиться от проблем кроивого отображения форм в 1С.

2. Выборочно — Нажмите Получить настройки всех пользователей — отметьте галочками то — что нужно удалить и нажмите Удалить помеченные. Данный способ позволяет удалить только те настройки, которые вы считаете проблемными или не нужными.

  • ПОСМОТРИТЕ:
  • Купить 1С
  • Цены на услуги по 1С
  • Программист 1С
  • СКАЗАТЬ СПАСИБО
  • ПОДЕЛИТЕСЬ:

1С. Очистка произвольных настроек из хранилища системных настроек

В ИБ с конфигурацией УТ 11 у всех пользователей очистить настройки формы элемента справочника «Номенклатура».

Решение

В конфигурациях на БСП есть утилита копирования/очистки настроек пользователя, но в некоторых ситуациях, обработка очищает не все настройки.

Настройки хранятся в хранилище системных настроек, получим выборку и в цикле будем сообщать значения настроек.

Выборка = ХранилищеСистемныхНастроек.Выбрать(); Пока Выборка.Следующий() Цикл ТекстСообщения = "КлючНастроек " + Выборка.КлючНастроек + "; КлючОбъекта " + Выборка.КлючОбъекта + "; Пользователь " + Выборка.Пользователь + "; Представление" + Выборка.Представление; ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщения); КонецЦикла; 

В окне сообщение получим примерный текст:

КлючНастроек ; КлючОбъекта Справочник.ВидыНоменклатуры.ФормаСписка/Такси/НастройкиОкна; Пользователь Пользователь1; Представление КлючНастроек ; КлючОбъекта Справочник.ВидыНоменклатуры.ФормаЭлемента/Такси/НастройкиОкна; Пользователь Пользователь1; Представление КлючНастроек ; КлючОбъекта Справочник.ВидыНоменклатуры.ФормаВыбораГруппы/Такси/НастройкиОкна; Пользователь Пользователь1; Представление КлючНастроек ; КлючОбъекта Справочник.ВидыНоменклатуры.ФормаВыбора/Такси/НастройкиОкна; Пользователь Пользователь1; Представление КлючНастроек ; КлючОбъекта Справочник.Номенклатура.ФормаСписка/Такси/НастройкиОкна; Пользователь Пользователь1; Представление КлючНастроек ; КлючОбъекта Справочник.Номенклатура.ФормаЭлемента/Такси/НастройкиОкна; Пользователь Пользователь1; Представление КлючНастроек ; КлючОбъекта Справочник.Номенклатура.ФормаВыбораГруппы/Такси/НастройкиОкна; Пользователь Пользователь1; Представление КлючНастроек ; КлючОбъекта Справочник.Номенклатура.ФормаВыбора/Такси/НастройкиОкна; Пользователь Пользователь1; Представление

Проанализировав текст дописываем в наш код проверку на ключа объекта и при необходимости будем удалять настройку

Выборка = ХранилищеСистемныхНастроек.Выбрать(); Пока Выборка.Следующий() Цикл Если Найти(Выборка.КлючОбъекта, "Справочник.Номенклатура.Форма.ФормаЭлемента") > 0 Тогда ТекстСообщения = "КлючНастроек " + Выборка.КлючНастроек + "; КлючОбъекта " + Выборка.КлючОбъекта + "; Пользователь " + Выборка.Пользователь + "; Представление" + Выборка.Представление; ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщения); ХранилищеСистемныхНастроек.Удалить(Выборка.КлючОбъекта, Выборка.КлючНастроек, Выборка.Пользователь); КонецЕсли; КонецЦикла; 

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *